RazerID : Intermittent login issues
Incident Report for Razer
Resolved
This incident is resolved. The service has been fully restored back to availability.
Posted Jun 14, 2023 - 10:22 PDT
Identified
The issue has been identified and a fix has been implemented.
Posted Jun 14, 2023 - 10:04 PDT
Investigating
We are experiencing intermittent login issues for RazerID. The team is investigating the matter with priority.
Posted Jun 14, 2023 - 07:47 PDT
This incident affected: Razer ID.