RazerID : Degradation of service

Incident Report for Razer

Resolved

This incident has been resolved.
Posted Oct 20, 2025 - 21:26 PDT

Monitoring

The cloud service provider has implemented fixes, and we are seeing recovery in the previously degraded services.
Posted Oct 20, 2025 - 14:08 PDT

Update

The Cloud Service Provider is still working towards a full resolution. Service degradation continues to be observed.
Posted Oct 20, 2025 - 08:16 PDT

Identified

team is working with the Cloud Service Provider to recover the service. Service degradation is still observed.
Posted Oct 20, 2025 - 01:26 PDT

Update

We are continuing to investigate this issue.
Posted Oct 20, 2025 - 01:03 PDT

Investigating

RazerID service degradation observed.
We are currently investigating the issue.
Posted Oct 20, 2025 - 01:02 PDT
This incident affected: Razer ID and Razer Synapse.