Unable to Access RazerID and Razer Gold Websites
Incident Report for Razer
Resolved
This incident has been resolved.
Posted Jul 22, 2021 - 10:52 PDT
Monitoring
A fix has been implemented for RazerID and Razer Gold, and we will continue to monitor.
Posted Jul 22, 2021 - 10:01 PDT
Update
Payment services on Razer Gold are still having issues. We are continuing to work on a fix for Razer Gold.
Posted Jul 22, 2021 - 09:52 PDT
Update
Razer Gold is partially online. We are continuing to work on a fix for Razer Gold.
Posted Jul 22, 2021 - 09:21 PDT
Update
RazerID is back online. We are continuing to work on a fix for Razer Gold.
Posted Jul 22, 2021 - 09:10 PDT
Identified
The issue has been identified and a fix is being implemented.
Posted Jul 22, 2021 - 09:09 PDT
Investigating
We are currently investigating this issue.
Posted Jul 22, 2021 - 09:00 PDT
This incident affected: Razer ID and Razer Gold & Silver.